Twist - Some users couldn't log into Twist – Incident details

All systems operational

Some users couldn't log into Twist

Resolved
Partial outage 30 %
Started about 13 hours agoLasted less than a minute

Affected

Web application & API

Operational from 4:00 PM to 4:00 PM

Website

Operational from 4:00 PM to 4:00 PM

Updates
  • Update
    Update
    This incident has been resolved.
  • Resolved
    Resolved

    A recent update prevented some users from logging into their workspace in Twist correctly. However, our development team has reversed the change, and it should be functioning properly now. We apologize for the inconvenience!