Twist - Twist is not syncing – Incident details

All systems operational

Twist is not syncing

Resolved
Major outage
Started 22 days agoLasted about 6 hours

Affected

Web application & API

Major outage from 12:08 PM to 6:08 PM

Website

Major outage from 12:08 PM to 6:08 PM

Updates
  • Resolved
    UTC
    Resolved

    This incident has been resolved. Twist is functioning normally again, and there should be no further delays or sync problems. We sincerely appreciate your patience and apologize for any inconvenience this may have caused!

  • Investigating
    UTC
    Investigating

    We are currently experiencing a sync issue with Twist. Some users may notice delays in updating threads and messages, or they may not sync at all. Our development team is actively investigating this issue. We will keep you updated!