All systems operational

Server maintenance

Completed
Scheduled for May 11, 2024 at 7:00 PM – 7:30 PM

Affects

Web application & API
Updates
  • Completed
    May 11, 2024 at 7:30 PM
    Completed
    May 11, 2024 at 7:30 PM
    Maintenance has completed successfully
  • In progress
    May 11, 2024 at 7:00 PM
    In progress
    May 11, 2024 at 7:00 PM
    Maintenance is now in progress
  • Planned
    May 11, 2024 at 7:00 PM
    Planned
    May 11, 2024 at 7:00 PM

    We’ll apply service updates to our data storage servers. As a result, the Twist’s servers may not be available during this maintenance window. If you’re logged in to Twist, you’ll still be able to see all your messages, but you won’t be able to post anything until the maintenance has been completed.