Twist - Twist can't be reached for certain users – Incident details

All systems operational

Twist can't be reached for certain users

Resolved
Partial outage
Started 23 days agoLasted about 2 hours

Affected

Web application & API

Partial outage from 3:18 PM to 5:19 PM

Website

Partial outage from 3:18 PM to 5:19 PM

Updates
  • Resolved
    Resolved

    The DNS resolution issue has been resolved. Everything should be working as intended again.

  • Update
    Update

    We're sincerely sorry for the disruption this incident is causing some of our users. Our developers are still working towards a solution.

  • Investigating
    Investigating

    We are currently investigating this DNS-related issue. We'll report back here once we've figured out the cause. Sorry for the inconvenience this is causing!